FluentLenium 1.0 and 3.0 brings many new features but also comes with breaking changes.

If you have some tests written using previous version, reading this guideline should help you to migrate.

Maven

You need to upgrade surefire, failsafe and maven-compiler plugins

<plugin>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>3.8.0</version>
    <configuration>
        <release>11</release>
    </configuration>
</plugin>
<plugin>
    <artifactId>maven-surefire-plugin</artifactId>
    <version>3.0.0-M1</version>  
</plugin>
<plugin>
    <artifactId>maven-failsafe-plugin</artifactId>
    <version>3.0.0-M1</version>
</plugin>

Some of other dependencies may require to be bumped-up because of the new Java version.

There is no other big changes but JVM 11 brings tons of performance improvements and it is significant change that’s why we decided to upgrade.

Something wrong ?

You may open issue if something wrong occurs during migration.